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Introduction 
Photomatix Pro processes multiple photographs of a high contrast scene into a single image 
with details in both highlights and shadows.  

Photomatix offers two types of processes to increase the dynamic range. One process is called 
HDR Tone Mapping, the other Exposure Blending. Both processes are designed to produce an 
image with an increased apparent dynamic range, but their results are different. You should try 
both and then choose the result that works best with your images.  

The first section of this manual provides tips for taking photographs intended for High Dynamic 
Range (HDR) processing in Photomatix Pro. The second section describes how to create HDR 
images and process them through Tone Mapping. The third section deals with the Exposure 
Blending functions, and the fourth section with the Batch Processing tool. Finally, section five 
provides a few tips and techniques. 
 
 
 

The following icons are used throughout the manual: 

  Useful information and important notes. 

  Tips and recommendations. 
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Drag-and-drop  
You can directly access the HDR creation or Exposure Blending processes by dragging and 
dropping to Photomatix Pro a group of image files of the same scene taken under different 
exposures. On Windows, you can drag the files from Windows Explorer and drop them on the 
opened Photomatix Pro program. On Macintosh, you can drag the files from the Finder and drop 
them on the Photomatix Pro icon on your Dock. You can also drag images from other image 
browsers. 

Note that you need to drag the image files belonging to the same exposure sequence together 
in order to have them taken into account for the HDR creation and Exposure Blending 
processes. 

 

Workflow Shortcuts panel 
The functions of Photomatix Pro can be accessed via the menus. To allow faster access, some 
core functions can be launched via the “Workflow Shortcuts” panel.
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Section 1: Taking photos for HDR  
 
The shooting phase is essential for getting good results with Photomatix. To photograph a high 
contrast scene, you need to take several exposures in order to capture information in both the 
highlights and the shadows of the scene. The exposures taken will have to properly cover the 
dynamic range of the scene, especially the shadows. 

The number of photos you need depends on the scene. It also depends on the Exposure Value 
(EV) spacing separating the photos. If you take them in one-EV steps (e.g., -1, 0, +1 EV), you 
will need more photos than if you take them in two-EV steps (e.g., -2, 0, +2 EV). We 
recommend shooting in two-EV steps whenever possible. 

High contrast scenes can be grouped into roughly two types depending on their dynamic range: 

 Medium dynamic range scene: Most landscapes and other types of outdoor scenes fall 
into this category. Three exposures taken in two-EV steps (i.e. –2, 0 +2 EV), or five 
exposures taken in one-EV steps, are usually sufficient for this type of scene. 

 High dynamic range scene: A typical example is the interior of a room with a view 
outside the window on a sunny day. You need to take at least five exposures in two-EV 
steps (or nine exposures in one-EV steps) to capture this type of scene, but you may need 
more. Taking the exposures manually is recommended in these cases.   

 
The source photographs for HDR processing can be taken with digital or film-based cameras.  
The only requirement is that the exposure can be adjusted when taking pictures. If you use a 
film-based camera, you will need to scan the photographs into your computer before processing 
them (see subsection 1.3 below). 

1.1 Camera set up  
Set your camera to Aperture priority (A setting) so that only the shutter speed 
varies between the exposures.   
Select a low ISO (e.g., ISO 100 or lower). 
Turn the flash off. The flash may try to balance the exposure of all the images, when 
a range of exposures is the goal. 
Whenever possible, mount the camera on a tripod. Even though Photomatix Pro 
offers automatic alignment of hand-held photos, using a tripod is always better.  

 
DSLR cameras and some compact digital cameras offer Automatic Exposure Bracketing (AEB). 
This enables you to automatically take three or more exposures in a row: one at the proper 
exposure, one or more underexposed, and one or more overexposed.  Follow these steps if 
your camera offers AEB mode: 

Select the Continuous shooting mode on the camera’s drive setting. Consult your 
camera manual for model-specific instructions for using this setting.  
Set the camera to Auto Exposure Bracketing (AEB)  
 If possible, use the camera’s self-timer setting, or a cable release to minimize 
camera shake. 
Set the exposure increment to +/- 2 for optimal exposure range. If your camera does 
not offer +/- 2 exposure increments, select the maximum possible. Consult the camera 
manual for model-specific instructions for choosing this setting. 
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Note: The continuous shooting mode may not always be the best strategy because camera 
shake may build up. We recommend using a method that ensures the least possible shake for 
each single shot, e.g. mirror lock-up functionality, if available.  

 

 
AEB settings at the top of the LCD of a Nikon D80 (3 shots with +/- 2EV) 

 

 

Canon Rebel XTi/400D LCD showing AEB with +/-2 increments selected
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1.2 Selecting the exposures  
To get good results with HDR processing, your capture sequence must include photos that 
correctly expose highlights and photos that correctly expose shadows. The latter is especially 
important to avoid noise showing in the processed HDR image.  

In the lightest photo of the sequence, the darkest shadows should be at least in the mid-tones. 
You can check that with your camera’s histogram preview in playback mode. In your most 
overexposed photo, the left part of the histogram should be empty until 1/3rd of the histogram’s 
width. If this is not the case, you will have to add one or more photos taken with longer exposure 
times. Another option is to re-shoot the exposure sequence with the normal exposure set one or 
more EVs higher if your most underexposed image in the exposure sequence was too dark. 
This is the case when the histogram of your darkest image is completely empty on the right half.  

The number of exposures needed depends on the dynamic range of the scene, in addition to 
the exposure increment. For most outdoor scenes, three exposures taken at +/- 2 exposure 
increments will be sufficient, provided the scene does not include the sun. However, for the 
interior of a room with a bright view out the window, you will need at least five images taken with 
an exposure increment of +/- 2, or nine images taken with an exposure increment of +/- 1.  

In scenes with extreme differences between light and dark details, you should change the 
exposures manually to ensure you capture a wide enough range to cover your scene.  

1.3 Taking photos for HDR with film-based cameras 
 Follow the camera setup listed at the top of subsection 1.1 and the tips on selecting 
exposures in subsection 1.2. Keep in mind that you will not have the option of previewing 
the live histogram to determine your exposure range.  
Scan film or slides, not prints. Photo labs will attempt to make the best print from each of 
your source images, and you will not achieve good results scanning these for HDR 
generation. 
 Turn off your scanner’s auto-exposure options. This allows you to manually control the 
exposure. 
Make sure you select the “Align images” option in Photomatix Pro when combining your 
images. 
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Section 2: Creating an HDR image and processing it with Tone 
Mapping 
 
There are two steps involved in creating and processing HDR images:  

Step 1 merges your photos taken under different exposure settings into a single 32-
bit HDR image. Because of its high dynamic range, the 32-bit HDR image will not display 
properly on conventional monitors.  
Step 2 processes the 32-bit HDR image via the Tone Mapping tool. Tone Mapping 
will ‘reveal’ the dynamic range captured in the HDR image and produce an image that 
can be properly displayed on conventional monitors and is ready for printing. 
 

2.1 Creating a 32-bit HDR image 
The easiest way to load the bracketed photos you want to merge into an HDR image is by 
dragging them to the open Photomatix Pro application (Windows) or to the Photomatix icon in 
the Dock (Macintosh). Then, select the “Generate HDR image” option.  

Alternatively, you can also click on the “Generate HDR Image” button of the Workflow Shortcuts, 
or choose Process > Generate HDR.  

If you have Lightroom, you should use the Lightroom Export Plug-in to Photomatix Pro for 
your RAW files. Please refer to section 5 of this manual. 

If you have not dragged and dropped your images, click on the “Browse” button of the 
“Generate HDR – Selecting source images” dialog. An Open panel will be displayed to allow 
you to select your photos taken under different exposure settings. Highlight the image files that 
you want to merge into an HDR image. Then, click on the “Select” button, and click “OK” to 
proceed further. 

In case the exposure information cannot be found in the metadata of the image files, Photomatix 
will show a dialog where you can input the relative Exposure Values for each one of your 
images. This dialog will also be displayed if two or more source images share the same 
exposure information. 

 The order of the files in a bracketing sequence does not matter. Photomatix Pro will 
systematically sort the image files based on the exposure information retrieved from the 
EXIF data. If the exposure information is not available in EXIF data, Photomatix will use 
the relative brightness levels of the photos. 

 
Photomatix Pro can generate an HDR image from 8-bit, 16-bit, and RAW source files. 
Supported file types include JPEG, TIFF, PSD, DNG, and RAW files from many camera models. 
As the list of supported camera models for RAW files often changes when a new sub-version of 
Photomatix Pro is released, we suggest that you consult the Photomatix Pro FAQ on the 
HDRsoft website at http://www.hdrsoft.com/support/raw.html to check whether your camera 
model is supported. If your camera model is relatively new, you may have to upgrade to a new 
version, or wait until Photomatix Pro adds support for it. 
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2.1.1 Settings for Generate HDR 
 

 

The “Don’t crop” option is useful when the resulting images must have the same width and 
height as the source images.  

Chromatic aberrations reduction 

This option attempts to automatically correct color fringing due to chromatic aberrations of the 
lens. Checking this option is recommended, given that chromatic aberrations tend to show 
around high contrast edges, and are thus particularly an issue for HDR images.  

Noise reduction 

This option reduces chromatic noise and, to a lesser extent, luminance noise. This option is 
recommended when you are processing RAW files directly in Photomatix. Note that the noise 
reduction is done on the HDR image itself once it has been created. This means that you don’t 
have to check the noise reduction option on the dialog for generating the HDR image when you 
need noise reduction. You can apply noise reduction to your HDR image later on by choosing 
Utilities > Reduce Noise.  

Ghosting reduction settings 

Ghosting artifacts appear when combining images of a dynamic scene. Photomatix Pro offers 
options to reduce two types of ghosting artifacts. The option “Background movements” reduces 
ghosting artifacts caused by background elements that follow a rhythmic pattern (flowing water, 
for instance), oscillating between shadows and highlights. The “Moving objects/people” option 
attempts to reduce the ‘ghosts’ in the combined image due to moving persons, animals or 
objects.  

It is important to note that selecting “Moving objects/people” lowers the quality of the resulting 
HDR image. Only select this option if it is really necessary, and try first with “Detection” set to 
“Normal”.  

Tone curve options 

The recommended option, “Take tone curve of color profile”, is selected by default. This is 
usually the best choice when the image files come from a DSLR camera or have been 
converted from RAW files. This option loads the Tone Reproduction Curve data from the ICC 

Alignment settings 

The “Align source images” option is checked by 
default. This option corrects misalignment problems 
when the camera moves slightly between the 
bracketed frames. This always happens with hand-
held photographs, but may even happen when 
shooting with the aid of a tripod.  

Photomatix Pro offers two alignment methods. The 
first one, “By correcting horizontal and vertical shifts”, 
is fast but corrects for translation movements only. 
The second one, “By matching features”, corrects for 
both rotation and translation, and is recommended 
for hand-held shots. Given that each method is 
based on a different algorithm, try the other one 
when one fails. 
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color profile associated with the source images in order to determine the non-linear function 
applied to the raw sensor’s data. If no profile is available, it uses the tone reproduction curve of 
the Adobe RGB color profile. 

When the images are scanned films or taken with a compact camera, it may be worthwhile to 
check the option “Attempt to reverse-engineer tone curve applied”.  

If your source images are 16-bit TIFF files that have been converted from RAW files with a RAW 
converter that allow the image to be left in linear space (note: very few RAW converters allow 
this), then check the option “No tone curve applied – pixel values are linear”. Only check this 
option if you are 100% sure that the tonal values of the images are linear relative to the values 
of light captured. Please note that the term “linear” may have a different meaning depending on 
the RAW converter. In Adobe Camera Raw, for instance, linear is relative to the Adobe RGB 
color space and not to the values of light, so you should never check this option with files 
converted with Photoshop or Lightroom.  

RAW conversion settings 

When your source images are RAW files, the dialog shows options to let you select a white 
balance and color primaries. 

 

By default, Photomatix will use the “As Shot” White Balance (read from the EXIF metadata) 
when converting the RAW data to HDR. You can adjust the White Balance by selecting a pre-
defined white balance from the drop-down menu, or by specifying the color temperature in 
Kelvin. A preview lets you see the effect of the change on the source image.  

The RAW data is in a color space specific to the camera. Photomatix will convert the data into a 
standardized color space (by default Adobe RGB). You can, however, select sRGB or ProPhoto 
RGB instead. Please note that the selected color space is used for the color primaries only, and 
not for the tone reproduction curve. Since the HDR image values are in linear space, they do 
not have a tone curve. The tone curve of the profile associated with the image will only be 
applied during the tone mapping step, and not to the HDR image itself.
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2.1.2 Comments on the generated HDR image 
 
In the companion “HDR viewer” window, the small image area at the top displays a zoomed-in 
section of the properly exposed HDR image at the current pointer location. 

The generated 32-bit HDR image is in an unprocessed state, which means that the large range 
of highlight and shadow details contained in the HDR image cannot be properly displayed on 
screen at this stage. An unprocessed HDR image is, in a way, similar to a film negative or the 
RAW file of a digital camera. The image needs further processing, called Tone Mapping, for 
display or printing.  

Saving the 32-bit HDR image at this point will allow you to apply different Tone Mapping 
settings to the HDR source image without repeatedly following the “Generate HDR” procedure. 
Photomatix Pro saves the name of the color profile in the header of an HDR image saved in the 
Radiance (.hdr) format. This means you will not have to re-assign the color profile, provided the 
HDR image file have been saved as Radiance and the color profile is either sRGB, Adobe RGB 
or ProPhoto RGB. However, the color profile information of the source images will not be 
preserved if the HDR image has been saved in the OpenEXR format.  

Photomatix Pro allows you to create a 32-bit HDR image from a single RAW file. 
To do this, open one RAW file using File >Open, and Photomatix will convert it into a 
pseudo-HDR image. It is important to note, though, that an image created with a single 
RAW file cannot really be considered High Dynamic Range. The important characteristic 
of this pseudo-HDR image is that it is unprocessed. Its dynamic range is not much larger 
than the range of an already converted file. 
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2.2 Processing the HDR image with Tone Mapping 
Tone Mapping is necessary to reveal the details in shadows and highlights in your 32-bit HDR 
image created from multiple exposures. You can either use Tone Mapping immediately after 
having generated an HDR image or after opening an existing HDR image file that was 
previously saved. To access the Tone Mapping tool, click on the “Tone Mapping” button on 
either the HDR Viewer window or the Workflow Shortcuts window, or choose Process >Tone 
Mapping. 

Photomatix Pro offers two tone mapping methods: 

 The Details Enhancer method is based on a local operator, which means that it takes 
into account the local brightness context for tone mapping. Pixels are processed differently 
depending on whether they are located in a bright or dark area of the image. This method 
offers settings that let you process the image in creative ways. 

 The Tone Compressor method is based on a global operator, which means that pixels 
are processed independently of their surroundings. This method produces more ‘natural-
looking’ results. 

When you start the Tone Mapping tool, you will get two windows:   

1) The “Tone Mapping Settings” dialog provides sliders to adjust the tone mapped image to 
your liking. The dialog also lets you save presets or load existing ones. The tabs on top 
of the dialog let you switch between the two tone mapping methods. The “Process” 
button at the bottom of the dialog will process the entire HDR image so that you can then 
save it.  

2) The “Tone Mapping Preview” window provides a preview of what the image will look like 
once the Tone Mapping has been applied to the entire HDR source image and includes 
options to adjust the size of the preview. Note that, in the case of the Details Enhancer 
method, the preview is not always an accurate representation of the final tone mapped 
image. 
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2.2.1 General controls  
 
The image adjustment controls are specific to the tone mapping method activated and are 
described in the next subsection. The Tone Mapping Settings and Preview dialogs include 
additional general controls, which apply to both tone mapping methods. 

Preview size 

The radio button across the top of the Preview dialog let you choose between four sizes for the 
preview. “small”, “medium” and “large” are fixed size while “fit” is based on the size of your 
screen on Macintosh and on the size of the opened application on Windows.  

Loupe 

When you move the mouse over the preview, you will see a square marquee. If you click on 
some position, the content of that square will show up at 100% resolution in the “Loupe” panel. 
You can use the option “Refresh Loupe only” to avoid refreshing the main preview when you 
change settings. This will speed up the view refresh inside the Loupe window.  

Reset, Undo & Redo 

 At the bottom of the Tone Mapping Settings dialog, the “Undo” 
(arrow to the left) and “Redo” (arrow to the right) buttons let you 
undo and redo changes you made to the settings. 

 

Presets 

The “Presets” menu lets you quickly access default or previous 
settings, as well as specific settings you had defined earlier. It also 
allows you to save the current settings and load settings available 
outside the Presets location.  
 

Default: Sets to the default “factory” values.  

Previous: Recalls the values set the last time you used the tone 
mapping tool. 

List of saved presets: e.g. here “VeniceMask”, which had been 
saved during a previous session using “Save Settings” 

Load Settings...: Load settings previously saved via “Save Settings” outside the Presets 
folder.  

Save Settings..: Save settings either in the Presets folder or elsewhere. When they are 
saved in the Presets folder, they will show in the list of Presets for quick access. 
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2.2.2 Details Enhancer controls  
 
The controls for the Details Enhancer tone mapping method are divided into four groups. The 
general adjustments appear at the top of the Tone Mapping Settings dialog, while further other 
adjustments (“Tone Settings”, “Color Settings” and “Smoothing Settings”) are located under 
expandable sections. 
 

General settings 

  

 

Luminosity  

Controls the compression of the tonal range, which has the effect of adjusting the global 
luminosity level. Moving the slider to the right boosts shadow details and brightens the image. 
Moving it to the left has the opposite effect, and gives a more “natural” look to the resulting 
image. The default value is 0. 

Light Smoothing  

Controls smoothing of the contrast variations throughout the image. This setting has an 
important influence on the look of the tone mapped image. High values give a more “natural” 
look, low values a more “artificial” or “painterly” look. The default value is “High”. 

Microcontrast  

Sets the level of accentuation of local details. The default value is 0. 

 

Strength  

Controls the strength of the contrast enhancements. A 
value of 100 gives the maximum increase in both local and 
global contrast enhancements. The default value is 70. 

Color Saturation 

Controls the saturation of the RGB color channels. The 
greater the saturation, the more intense the color. A value 
of 0 produces a grayscale image. The value affects each is 
46

Strength  

Controls the strength of the contrast enhancements. A 
value of 100 gives the maximum increase in both local and 
global contrast enhancements. The default value is 70. 

Color Saturation 

Controls the saturation of the RGB color channels. The 
greater the saturation, the more intense the color. A value 
of 0 produces a grayscale image. The value affects each 
color channel equally. The default value is 46. 
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Tone settings 

 

Gamma  

Adjusts the mid-tone of the tone mapped image, brightening or darkening the image globally. 
The default value is 1.0. 

 

Color settings 

 

 

Saturation Highlights  

Adjusts the color saturation of the highlights relative to the color saturation set with the Color 
Saturation slider. Values higher than 0 increase the color saturation in the highlights; values 
lower than 0 decrease it. The default value is 0. 

Saturation Shadows 

Adjusts the color saturation of the shadows relative to the color saturation set with the Color 
Saturation slider. Values higher than zero will increase the color saturation in the shadows. 
Values lower than zero will decrease it. The default value is 0. 

White Point – Black Point  

Both sliders control how the minimum and maximum values of 
the tone mapped image are set. Moving the sliders to the right 
increases global contrast. Moving them to the left reduces 
clipping at the extremes. The White Point slider sets the value 
for the maximum of the tone mapped. The Black Point slider 
sets the value for the minimum of the tone mapped image. The 
default value is 0.25% for the White Point setting and 0% for 
the Black Point setting. 

Temperature  

Adjusts the color temperature of the tone mapped 
image relative to the temperature of the HDR source 
image. Moving the slider to the right will give a 
“warmer”, more yellow-orange colored look. Moving the 
slider to the left gives a “colder” more bluish look. A 
value of 0 (default) preserves the original color 
temperature of the HDR source image. 
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Smoothing settings 

 

Highlights Smoothing 

Reduces the contrast enhancements in the highlights. The value of the slider sets how much of 
the highlights range is affected. This control is useful for preventing white highlights from turning 
grey, or uniform light blue skies becoming dark blue-grey. It is also useful for reducing halos 
around objects placed against bright backgrounds. The default value is 0. 

Shadows Smoothing 

Reduces the contrast enhancements in the shadows. The value of the slider sets how much of 
the shadows range is affected. The default value is 0. 

Shadows Clipping 

The value of the slider sets how much of the shadows range is clipped. This control may be 
useful to cut out noise in the dark area of a photo taken in a low-light situation. The default value 
is 0. 

 

Other Settings 

360º image 

Checking this option eliminates the seam between the left and right sides of a panorama viewed 
in a 360º panoramic viewer. The seam would otherwise show because Details Enhancer takes 
into account local contrast, assigning different tonal values to the right and left parts of the 
image. The default value is unchecked. Note that this option is not enabled when the image is in 
portrait mode, as the option is intended for panoramas. 

 

Micro-smoothing  

Smoothes out local detail enhancements. This has the 
effect of reducing noise in the sky for instance, and tends 
to give a “cleaner” look to the resulting image. The default 
value is 2. 

 Important note: The Loupe may not properly show the 
effect of the Micro-smoothing setting when the area 
magnified is uniform. If you want to see the effect of the 
Micro-smoothing setting at 100% resolution on a uniform 
area such as the sky, you will have to select an area that 
contains an object in the scene in addition to the sky. 
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2.2.3 Tone Compressor controls  

Brightness 

Adjusts the overall brightness of the tone mapped image. The default value is 0. 

Tonal Range Compression 

Controls the compression of the tonal range. Moving the slider to the right has the effect of 
shifting both shadows and highlights toward the mid-tones in the tone mapped image. The 
default value is 0. 

Contrast Adaptation 

Adjusts the influence of the average brightness in relation to the intensity of the processed pixel. 
Moving the slider to the right tends to result in more “pronounced” colors. Moving the slider to 
the left tends to result in a more “natural” look. The default value is 0. 

White Point – Black Point  

Both sliders control how the minimum and maximum values of the tone mapped image are set. 
Moving the sliders to the right increases global contrast. Moving them to the left reduces 
clipping at the extremes. The White Point slider sets the value for the maximum of the tone 
mapped image (pure white, or level 255). The Black Point slider sets the value for the minimum 
of the tone mapped image (pure black, or level 0). The default values are 0. 

Color Temperature  

Adjusts the color temperature of the tone mapped image relative to the temperature of the HDR 
source image. Moving the slider to the right will give a “warmer”, more yellow-orange colored 
look. Moving the slider to the left gives a “colder”, more bluish look. A value of 0 (default) 
preserves the original color temperature of the HDR source image. 

Color Saturation 

Adjusts the color saturation of the tone mapped image. The greater the saturation, the more 
intense the color. The value affects each color channel equally. The default value is 0. 
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2.2.4 Processing and saving the tone mapped image  
 
Once you are satisfied with the settings, click the “Process” button to apply the tone mapping to 
the complete image (instead of the preview only). You will then be able to save the tone 
mapped image by choosing File > Save As.   

 If you would like to undo the Tone Mapping, click the “Undo Tone Mapping” item of 
the “Process” menu on Windows and the “Edit” menu on Macintosh. The tone mapped 
image will revert to a 32-bit HDR image, which can then be tone mapped again. 

The resulting tone mapped image always has a bit depth of 16 bits/channel. On the “Save” 
panel, the File Type menu offers the following options:  

TIFF – 16bit: Best choice for further processing 
TIFF – 8bit: For use in applications that cannot deal with 16 
bit, or for avoiding too large file size on disk 
JPEG:  For use on the web without further editing 

 

 Choosing File>Save settings will save the applied tone mapping settings as an XMP   
file so you can easily reproduce the same Tone Mapping process in the future. 

 

If you save the tone mapped image as a TIFF file, the tone mapping settings will be 
automatically embedded as XMP metadata in the TIFF file.  If you open the file in Photoshop, 
you can then view the tone mapping settings under File >Info >Advanced. 
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Section 3: Exposure Blending 
Exposure Blending is the process of combining your photos under multiple exposures into one 
image with details in both shadows and highlights. The resulting image with increased dynamic 
range is achieved in one step with Exposure Blending, whereas HDR Tone Mapping requires 
two steps. Exposure Blending is also known as Exposure Fusion. 

Exposure Blending offers several advantages over the HDR and Tone Mapping workflow 
described in the previous section: 

 Blending the images has the effect of reducing noise whereas HDR and tone mapping 
may amplify it. 
 The blended image does not differ much from the source images, giving it a more 
natural look. 
 Exposure Blending is a simple and easy-to-understand process, with no or few 
parameter settings. 
 

On the other hand, Exposure Blending may not always work well when the dynamic range of the 
scene is high. This can result in a lack of local contrast and a “flat” look. Also, the memory 
required for blending exposures increases with the number of source images and their bit-depth, 
whereas the memory required for Tone Mapping depends only on the width and height of the 
image. 

 When your source images are RAW files, you should convert them in your favorite 
RAW converter before processing them with Exposure Blending in Photomatix. This is 
easy to do if you have Lightroom by using the Lightroom Export Plug-in to Photomatix 
Pro as detailed in section 5.
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3.1 Blending Exposures 
To start Exposure Blending, drag your images to the opened Photomatix Pro application 
(Windows) or to the Photomatix icon in the Dock (Macintosh). Then, choose “Blend exposures”.  

Alternatively, you can also click on the “Exposure Blending” button of the “Workflow Shortcuts”, 
or choose Process > Exposure Blending.  

If you have Lightroom, you should use the Lightroom Export Plug-in to Photomatix Pro for 
your RAW images. Please refer to section 5 of this manual. 

If you have not dragged-and-dropped your images, click the “Browse” button of the “Exposure 
Blending – Selecting source images” dialog. An “Open” panel will display to allow you to select 
your photos taken under different exposure settings. Highlight the image files that you wish to 
combine. Then click on the “ Select” button, and click “OK” to proceed further. 

The “Align Source images” option corrects for misalignment problems if the camera moved 
slightly between the bracketed frames. This is the case with hand-held photographs and may 
even happen when shooting with the aid of a tripod.  

Click on “OK” and the “Exposure Blending” dialog will appear. 

Select the Exposure Blending method of your choice. Some methods allow settings and some 
are fully automatic. Try different methods to get  the most pleasing results. The default method 
Highlights & Shadows – Adjust is often a good choice. 
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3.1.2 Highlights & Shadows – Adjust 

Accentuation 

Adjusts the strength of local contrast enhancements. The default value is 0. 

Blending Point 

Adjusts the weighting given to the underexposed versus overexposed images. When you move 
the slider to the right, overexposed images are favored, which has the effect of brightening the 
image. The reverse applies when you move the slider to the left. The default value is 0. 

Shadows 

Adjusts the brightness of the shadows without affecting the highlights. The default value is 0. 

Color Saturation 

Adjusts the saturation of the color channels. The greater the saturation, the more intense the 
color. A value of 0 produces a grayscale image. The default value is 0. 

White Clip 

Specifies how much the highlights are clipped. Moving the slider to the right increases contrast 
but removes details in the brightest highlights. The default value is 0. 

Black Clip 

Specifies how much the shadows are clipped. Moving the slider to the right increases contrast 
but removes details in the darkest shadows. The default value is 0. 

Midtones Adjustment 

Positive values brighten the image but reduce the overall contrast. Negative values darken the 
image but increase overall contrast. The default value is 0. 

3.1.2 Highlights & Shadows – 2 Images 
 
This method blends only two images. The dialog allows you to select which images are blended. 

3.1.3 Highlights & Shadows – Intensive 

Strength 

Adjusts the strength of local contrast enhancements. The default value is 0. 

Color Saturation 

Adjusts the saturation of the color channels. The greater the saturation, the more intense the 
color. A value of zero produces a grayscale image. The default value is 0. 

Radius 

Controls the area used to calculate the weighting of the source images. A higher radius reduces 
halos, but increases processing times significantly. The default value is 40. 
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3.2 Processing and saving the blended image 
Once you have found a method that gives you results you like, click the “Process” button to 
blend to the images at full resolution (instead of blending a low resolution for the preview). After 
the files are processed, you can save the blended image by choosing File > Save As.   

The resulting blended image always has a bit-depth of 16 bits/channel. This is even the case if 
the source images were JPEGs or 8-bit TIFF files. On the Save Panel, the File Type menu 
offers the following options:  

TIFF 16-bit: Best choice for further processing 
TIFF 8-bit: For use in applications that cannot deal with 16 bit, 
or for avoiding too large file size on disk 
JPEG:  For use on the web without further editing
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Section 4: Automating with batch processing 
 
Batch processing lets your computer automatically process image files with no user intervention. 
This can save you a lot of time when you have many series of photos to process. Photomatix  
Pro offers two different batch modes. Both are available under the “Automate” menu: 

Processing of series of bracketed photos: this is done with “Batch Processing”  
Processing of single image files: this is done with “Single File Conversion”  

 
The “Batch Processing” function, intended for series of bracketed photos, is particularly useful 
for creating 32-bit HDR image files ready to be tone mapped individually. If you open another 
session of Photomatix Pro, you can start working on the first images while Batch Processing is 
still processing the remaining exposure series. 

The “Batch Processing” function is also useful for trying different tone mapping or exposure 
blending methods for your source images. This way, you can then select the method that gives 
the best results for each exposure sequence. 

 

4.1 Using Batch Processing  
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Choose Automate > Batch Processing or click on the “Batch Processing” button on the 
Workflow Shortcuts panel. 

Note: This section describes the batch processing of photos taken under multiple exposure 
settings. In some cases, you may be interested in batch processing single files instead, such as 
tone mapping previously created 32-bit HDR image files saved as Radiance or OpenEXR. In 
such cases, you will have to use the “Single File Conversion” item under the Automate menu 
instead of “Batch Processing”. 

To batch process series of bracketed photos, do the following: 

1. Select the process(es) you want to run by clicking one or more checkboxes on the left 
hand side of the dialog. 

 
2. Using the pull-down menu below the checkboxes, select the number of multiple exposures 

to be combined. For instance, select 3 if your bracketed shots consist of three exposures 
each, i.e. when you have taken for each scene one photo at median exposure, one 
underexposed and one overexposed. 

 
3. In the “Source” frame, select the location of the folder where your bracketed photos are. 

The batch will arrange the files of this folder in alphabetical order. It will process N files at 
a time, N being the number you specified in step 2. 

 
4. If you want to save the results in a different folder than the folder containing your source 

photos, select the “Custom location” option in the “Destination” frame at the bottom right. If 
you leave the default option, “Created under source folder”, then the batch will create a 
subfolder with the name "PhotomatixResults" and will store the resulting images in this 
folder. 

 
5. In the “Destination” frame, select the output file type. 
 
6. Click the “Run” button to start batch processing. 

 
While the batch is running, the results area below the “Run” button will display the processing 
done.
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4.2 Settings specific to Batch Processing  
The “Settings...” buttons allow you to specify the settings for HDR generation, Tone Mapping, 
and Exposure Blending. Please refer to sections 2 and 3 for a description of these settings.  

In the case of the settings for Generate HDR, there are a few settings that are specific to Batch 
Processing and are described below: 

Force Exposure Values spacing to: 

The checkbox will force the EV spacing to the specified value. This option can be used when 
the exposure information is not available in the EXIF data (or if two or more images have the 
same exposure information), or to force the EV spacing in all cases. In the latter case, the 
exposure information in the EXIF data will be ignored.  

Source images are linear (no tone curve applied) 

This option is intended for 16-bit TIFF files that have been converted from RAW files with a 
RAW converter that allows the image to be left in linear space (note: very few RAW converters 
allow this). Only check this option if you are 100% sure that the tonal values of the images are 
linear relative to the values of light captured.  

Note: the term “linear” may have a different meaning depending on the RAW converter. In 
Adobe Camera RAW, for instance, linear is relative to the Adobe RGB color space and not to 
the values of light, so you should never check this option with files converted with Photoshop or 
Lightroom.  

Process strip by strip 

Check this option if the source images are large TIFF files. With this option, the HDR image file 
will be created in several passes, processing and loading only one strip of each image into 
memory at a time. One strip is composed of a limited number of rows set to not exceed around 
512 MB of RAM. This option is particularly useful when processing large panoramas. Note, 
though, that the alignment functions are not accessible when the “Process strip by strip” option 
is used. 

4.3 Batch processing subfolders 
When your bracketed series are located in multiple folders, they can all be processed in one 
run, provided they are in subfolders of the same parent folder. To do that, check the “Process 
subfolders” option at bottom of the “Source” frame on the Batch Processing dialog and select 
“sequentially”.  

When “Process subfolders sequentially” is selected, the batch will process the bracketed image 
files in one subfolder and then move on to the next subfolder, all of which are contained in the 
main parent folder. 

 When your bracketed sets are composed of varying numbers of exposures (for 
instance, one set has three exposures and another five exposures), you can use 
“Process subfolders sequentially” to combine the exposures in these sets in one run. To 
do that, place each set in a separate subfolder, group the subfolders under a parent 
folder, check “Process subfolders sequentially” and select “All” in the pull-down menu for 
the number of images to process at a time.  
 

If you are processing bracketed photos that will be part of a panorama, you may find it useful to 
be able to organize your photos in such a way that all exposures of the same levels are under 
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the same folder. Let's take as an example a panorama composed of four views that need to be 
stitched, with each view having been taken under three exposures: -2, 0, +2. You will then have 
12 photos, and may need to place them in three separate subfolders composed of four photos 
each as follows: 

- subfolder1 contains four photos part of the panorama taken at EV -2  
- subfolder2 contains four photos part of the panorama taken at EV 0  
- subfolder3 contains four photos part of the panorama taken at EV +2  

If you check “Process subfolders” and select “grouped by exposures”, the batch will combine the 
first file of subfolder1 with the first file of subfolder2 and the first file of subfolder3. The batch will 
then combine the second file of subfolder1 with the second file of subfolder2 and the second file 
of subfolder3, and so on for the third and fourth file of each subfolder.
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Section 5: Tips and Techniques 

5.1 Exporting images from Lightroom to Photomatix Pro 
If you have Lightroom, you can export your RAW files from Lightroom to Photomatix Pro. This 
way, you will benefit from the good-quality RAW conversion performed by Lightroom and  be 
able to load the converted files directly into Photomatix.  

The Lightroom Export plug-in to Photomatix is free and available for download from the HDRsoft 
website at http://www.hdrsoft.com/download/lrplugin.html. Please follow the installation 
instructions on the download page to install the plug-in. 

Once the plug-in has been installed, select your bracketed RAW image files in Lightroom, and 
then choose File > Plug-in Extras > Export to Photomatix Pro if you are using Lightroom version 
2 or  File > Export to Photomatix Pro if you are using Lightroom version 1.3 or 1.4. 

If you want to be able to adjust the export settings, choose File > Export... In the Export dialog, 
select the “Photomatix” section.  

Note that DNG for the file type of the exported file is not proposed as a pre-defined setting for 
exporting to Photomatix. This is because the main advantage of exporting from Lightroom is to 
take advantage of Lightroom's rendering, i.e. RAW conversion to TIFF or JPEG, and this 
advantage will be lost if you do not render the files before exporting them to Photomatix.  

Once you have processed in Photomatix Pro the images exported from Lightroom, you can then 
have the resulting tone mapped or blended image reimported back into Lightroom. To do that, 
choose File > Save As, check the box “Open saved image in” and select “Adobe Lightroom” on 
the list. 

5.2 Using Photomatix Pro with a single image file  
When your scene is not very high contrast, it is possible to use Photomatix Pro with a single 
shot, provided this has been taken in RAW mode. There are three ways to do that: 

 Technique 1: Open your RAW file in Photomatix to convert the file into a pseudo-HDR 
image, then tone map it. 
 Technique 2: Convert your RAW file into a 16-bit image in your favorite RAW converter, 
then open the 16-bit TIFF or PSD file in Photomatix Pro and tone map it. 
 Technique 3: Create two or three exposures in your RAW converter and combine them 
in Photomatix as if they were “real” exposures, then process them in Photomatix. 

 
Technique 3 generally gives the best results. Also, it has the advantage of working with 
Exposure Blending.  

For good results with the above techniques, it is important to ensure the lowest noise level at 
capture time. To do that, set the lowest ISO possible (ISO 100 for instance) and expose for the 
shadows when taking the RAW image, i.e., overexpose your shot. Even though the histogram of 
your camera may indicate that highlights will be lost, you should still be able to recover them 
during RAW conversion (unless the scene is too high contrast, but then a single image will not 
be sufficient for good results with Photomatix). 
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5.3 Processing RAW files in third-party RAW converters  
Even though Photomatix Pro can process RAW files from most camera models, we recommend 
converting RAW files using a third-party RAW converter (such as Photoshop, Lightroom, 
Aperture, DxO or other applications specialized in RAW conversion) before processing them in 
Photomatix Pro.  

When a third-party RAW converter is used, RAW images should be developed with the following 
settings (the screenshot shows the settings in Lightroom): 

 WB (White Balance): Same WB for all source photos. 
 Basic settings: Should be all set to 0. 

 

 
 

 Curves: Both Parametric and Point Curves should be linear. 
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5.4 Dealing with noise  
When you process your images using Exposure Blending, the blended image will tend to show 
less noise than the source images. This is because Exposure Blending works by directly 
combining your bracketed photos, and thus averaging out noise.  

However, when you create a 32-bit HDR image, your bracketed photos are assembled in linear 
space into an image that spans the full range of luminance values captured by the camera. If 
the lightest photo of your exposure sequence is not bright enough to expose the shadows of the 
scene, then the noise in the source photographs will be transferred to the HDR image. Noise in 
the HDR image will then be made more apparent by tone mapping, especially with Details 
Enhancer as this tone mapping method increases local details. 

Though Photomatix Pro includes an option to reduce noise on the generated HDR image, it is 
still always better to avoid noise at capture time as much as possible. There are two tips to 
ensure a low noise level: 

 Tip 1: Set a low ISO setting (ISO 100 or lower) whenever possible 

 Tip 2: Overexpose sufficiently, ensuring that the lightest image of your exposure 
sequence has its shadows in the mid-tones.  

5.5 Photomatix Pro and color management  
Photomatix Pro supports color management even if RAW files are processed. You should use 
the same working space in Photomatix Pro as you use in other image editors (e.g. Photoshop). 

Photomatix supports the three most popular working spaces: 

 sRGB: Used if your images are created only for the web. 
 Adobe RGB: Popular working space for printing if extremely saturated colors are not 
used. 
 ProPhoto RGB: Wide gamut working space. This should never be used for 8-bit images. 

 
For all JPEG and TIFF files, Photomatix Pro preserves the color spaces of the source files. 
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Resources 
 
You can find more tips and techniques, and regularly updated information, in the Photomatix 
Pro FAQ on the HDRsoft website at http://www.hdrsoft.com/support/faq_photomatix.html.   

 


